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CHAPTER 1
Welcome to Investoscope

Investoscope is an easy-to-use, all-in-one tool for tracking investment portfolios of
stocks, mutual funds, bonds and other instruments. With a detailed transaction record,
Investoscope accurately reports your capital gains and losses, distributions and perfor-
mance. Integrated technical charts and news help you investigate and analyze your
current and potential future investments.

1.1 About this User Guide

The next section (Section 1.2) is a quick start guide for the impatient. The following
chapters provide a more detailed treatment of Investoscope and may be read from start
to finish, but should probably just be used as a reference.

1.2 Quick Start Guide

In this section we will take you through the absolute basics of setting up your first
portfolio and entering your first transactions.

Creating a Portfolio The first thing you want to do to track you investments is to
create a portfolio. To do this, choose File > New > Portfolio. . . You will be asked for a
name and a currency for the portfolio.

Adding Cash Portfolios in Investoscope maintain a cash balance. To add initial cash
to a portfolio, you enter a Deposit transaction. To do that, choose Transactions > De-
posit. . . Investoscope will then display the following sheet:

1



1.2. Quick Start Guide 2

To finish the transaction, enter an amount and click the OK button.

Adding a Stock to the Library Now, to enter transactions for a stock, say General
Electrics, you’ll first need to add the stock to the library. To add a stock to the library,
first select the “Stocks” library item in the source list. Then choose File > New > Instru-
ment. . . In the search field, enter an appropriate search string, in this case “GE”:

Finally, select the appropriate search result and click the “Add” button.

Entering a Buy Transaction With General Electrics in the library, you can start adding
transactions for it. For example, to record a purchase transaction control-click (or right-
click) on GE in the instrument list to bring up the context menu, and then choose Buy. . . :



1.2. Quick Start Guide 3

This will bring up the following sheet:

To complete the transaction, fill out all the fields and click the OK button. You will now
see General Electric in the Holdings tab of your new portfolio:

That’s it!



CHAPTER 2
The Main Window

Almost everything in Investoscope happens in one window. Here is a quick glance of
what the main window looks like when you first launch Investoscope:

Investoscope's library contains 
all your instruments, i.e., your 
stocks, bonds, mutual funds, etc.

The sidebar lets you view 
and edit the details of the 
selected instrument. 

The instrument list 
displays the contents of the 
selected source item. Here 
the instruments are 
displayed in "Grid View." 

Switch the instrument list 
between "List View" and 
"Grid View".

Show or hide 
the sidebar

Context menu, activated by 
Control-clicking (or right-
clicking) an instrument.

The instruments in an instrument list can either be displayed as a grid of historical
charts or as a list. We refer to these views as grid view and list view, respectively. Above,

4



2.1. The Instrument Grid View 5

the instruments are displayed in grid view. You can switch to list view by choosing
View > as List from the menu. From the instrument list, you can go to the technical chart
of an individual instrument. Technical charts are explained in detail in Chapter 8.

2.1 The Instrument Grid View

The grid view is activated by choosing View > as Grid from the menu. The grid view
displays your instruments as a grid of historical charts:

At the top of the view, you can choose between different scales and time ranges. The
grid view is ideal for getting a quick overview of how the instruments you are following
are doing.

2.2 The Instrument List View

The list view is activated by choosing View > as List from the menu. The list view
displays your instruments in a table:

You can customize the displayed columns from the submenu View > Columns or by
Control-clicking the table header. The table layout can be saved for later use by choos-
ing View > Save Current View. . . . You can restore a previously saved view with the View
> Saved Views menu.



2.3. Finding Instruments 6

You can group the instruments in the list view by certain attributes, e.g., the market
country (the country of the market in which the instrument is traded), the market name,
the trade currency etc. The grouping attribute is chosen in the menu View > Group By.
In the screenshot above, the instruments are grouped by “Country”.

2.3 Finding Instruments

In any instrument list, you can quickly find and select an instrument by typing the first
letters of its name. Furthermore, you can filter out particular instruments by choosing
Edit > Find and entering a search query.

2.4 The Sidebar

The sidebar on the right side of the window (when visible) lets you view and edit
detailed information of the selected instrument(s). The sidebar consists of several panes
depending on the selected instrument(s).

The “Details” pane of the sidebar, shown above, holds the basic properties of an instru-
ment. The exact fields in the “Details” pane vary slightly depending on the type of the
selected instrument. The sidebar also contains a “News” pane, for funds an “Assets”
pane and for positions in portfolio, a “Positions” pane.



CHAPTER 3
The Library

The library contains all your instruments, i.e., you stocks, bonds, mutuals funds, indices,
etc. The library section of the source list has en entry for each instrument type in your
library:

3.1 Instrument Types

The following instrument types are supported:

• Stocks

• Mutual Funds

• ETFs

• Bonds

• Indices

• Miscellaneous (for everything that doesn’t fit in the above)

Empty sections are not displayed, so if you haven’t added any, say, bonds to your li-
brary, you will not see a Bonds item.

7



3.2. Adding New Instruments 8

3.2 Adding New Instruments

Before you can track a stock or any other instrument, you first need to add it to the
library. To add a new instrument to the library, choose File > New > Instrument. . . This
will bring up the instrument search sheet:

At the top of the search sheet, you select the type of the instrument that you are adding.
The search sheet lets you lookup instruments at the supported quote data sources. For
more information on quote data sources, see Chapter 4. In the search field, enter an
appropriate search query, e.g., the name or symbol of the instrument. Above, we have
entered “GE” which is the symbol for General Electric. Click the “Search” button or
press enter on the keyboard to begin the search. After a few moments, you should see
the result of the search. The icon on the left indicates what service is providing the data.

If you see the instrument you were looking for, you can add it to the library by first
selecting it and then clicking the “Add” button. If the instrument you were looking
for does not appear in the search results, you may first try to alter the search query
and repeat the search. If you still cannot find the instrument, it may not be covered by
any of the supported data sources. In that case, you can add the instrument as a blank
instrument with manual data entry. This is explained in the next section.

3.3 Adding an Instrument with Manual Data Entry

Instruments that are not covered by any of the supported data sources, can be added
to the library as blank instruments with manual data entry. To add such an instrument,
first choose File > New > Instrument. . . At the top of the search sheet, choose the instru-
ment type to add, e.g. Stock, and then click the “Add Blank Instrument” button. You
can then enter the details in the sidebar:
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3.4 Deleting Instruments

To delete an instrument from the library, first locate it in the library section and select
it. Then either press the delete key on your keyboard or choose Edit > Delete. However,
note that you cannot delete an instrument that is used in one or more of your portfolios.
For example, if you have Apple Inc. in one of your portfolios and you try to delete it
from the library, you see the following error message:

Note: Investoscope is shipped with a number of instruments in the library. Many of
these instruments are used by the sample portfolios that also ships with Investoscope.
Therefore, if you want to delete these instruments, you first need to delete the sample
portfolios.

3.5 Editing Instrument Values

The fields of a instrument, e.g., the name, the symbol or the latest price can be edited in
the sidebar. To change the value of a field, simply click on it and type in the new value:



3.6. News Feeds 10

3.6 News Feeds

The “News” pane of the sidebar lets you attach news feeds (RSS or Atom) to an instru-
ment:

You can use the checkbox on the entries to indicate that they have been read and then
hide them by chooseing File > Hide Checked News Entries.

3.6.1 Adding News Feeds

Investoscope has built-in news feed templates for Yahoo! Finance and Google Finance
that can be added from the menu File > Add News Feed.

To add a custom feed, you first need a suitable URL for the feed. For example, say
we want to add the business feed from Reuters to Apple Inc., the URL for this feed is:

http://feeds.reuters.com/reuters/businessNews

With Apple Inc. selected in the instrument list and the “News” pane visible in the
sidebar, we first choose File > Add News Feed > Add Custom Feed. . . and enter the URL:

http://www.reuters.com
http://feeds.reuters.com/reuters/businessNews


3.6. News Feeds 11

Now, since we are only interested in news regarding Apple inc., we click the “Filter”
disclosure triangle:

To apply filtering, we check the checkbox and add a rule to only display news entries
with “Apple” in the title. Finally, to add the feed, we click the OK button.

3.6.2 Editing or Deleting a New Feeds

To edit the settings of a news feed, hover the mouse over the title of the news feed and
click the menu button:
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Then, choose Feed Settings... to bring up the feed settings. To delete a news feed, choose
Delete Feed.

3.7 Colored Labels

Colored labels (or just Labels) provide an additional organizational element to instru-
ments besides watchlists and portfolios.

3.7.1 Setting Up Label Names

The first step to using labels is setting up the label names in the preferences. To set up
the label names, open the preferences by navigating to Investoscope > Preferences. . . and
choose the Labels pane:

Here you can specify names for specific label colors. By default, they’re labeled as
colors. You can change them to whatever criteria that makes sense to you.
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3.7.2 Labeling Instruments

To label an instrument, simply Control-click it to bring up the context menu and select
a label:

If you want to remove a label, select the ‘x’ in the context menu. Labels are displayed
as colored discs beside the name in instrument lists:

Here, Apple Inc. has been assigned the blue label.

3.8 Sectors and Industries

You can assign a sector and industry to each stock in your library. This is done in the
sidebar:

Note that the sector and industry is not set automatically by Investoscope. The set of
available sectors and industries can be edited by choosing View > Sectors/Industries. . .
This will bring up the following window:
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3.9 Asset Allocation of Mutual Funds and ETFs

The “Assets” pane in the sidebar for Mutual Funds and ETFs allows you to specify the
fund’s allocation into asset classes, market caps and sectors.
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These allocations are used to provide an accurate view of your portfolios diversification
(see Section 5).



CHAPTER 4
Quote Data and Data Sources

Investoscope automatically downloads both historical end-of-day quotes and current
price quotes from free sources on the internet.

4.1 Supported Data Sources

Currently, Investoscope supports Yahoo! Finance and Google Finance. Both services
cover a wide range of countries around the globe. For Yahoo! Finance, you can see the
list of supported exchanges here:

http://help.yahoo.com/l/us/yahoo/finance/quotes/fitadelay.html

And for Google Finance, the supported exchanges can be found here:

http://www.google.com/intl/en-US/help/stock disclaimer.html

4.2 Data Sources and Symbols

Data sources identify instruments using symbols also known as ticker symbols or just
tickers. Yahoo! Finance and Google Finance use slightly different symbols, so if you
change a data source, you usually also need to change the symbol. For example the
symbol for Apple Inc. on NASDAQ at Yahoo! Finance is “AAPL” whereas Google
Finance uses “NASDAQ:AAPL”.

4.3 Changing the Quote Feed

The data source and symbol used to fetch the current price quotes is set in the sidebar:

16
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We also refer to the data source for current price quotes as the quote feed. Above, the
quote feed is set to “Yahoo! Finance”. If we change it to “Google Finance” we must also
change the symbol:

If you set the quote feed to “Manual Data Entry”, the current price quote will not be
updated automatically. Instead, you can edit the current prices manually in the sidebar.

4.4 Changing Historical Quotes Source

By default when you add a new instrument, the end-of-day quotes are retrieved from
the same service as current price quotes. However, sometimes you may want to use
Yahoo! Finance for current price quotes and Google Finance for historical quotes (or
vice versa). The data source and symbol used for historical quotes can be changed
independently of the quote feed in the historical quotes window. To view the historical
quotes window, choose View > View Historical Quotes. . . :

Again, if you change the quote source, you should also update the symbol to match
that of the selected quote source.

4.5 Editing Historical Quotes

To view the historical quotes of an instrument, select the instrument and choose View >
View Historical Quotes. . . . This will bring up the historical quotes window:
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Historical quotes can be added manually. To add a new quote, click the + button.
To remove an existing quote, select and click the − button. You can change a value by
double-clicking it and typing in the new value.

4.6 Importing Historical Quotes

Historical quotes can be imported from a CSV file. To import historical quotes from a
CSV file, choose File > Import > Historical Quotes from CSV. . . and navigate to the CSV
file and click the OK button. Investoscope will then display the import panel:

Investoscope needs to know which column contains which quote field. If the import
file begins with a header row, Investoscope will attempt to guess the column assign-
ment from that. Otherwise, you assign a quote field to a column by clicking the column
header and choosing appropriate field from the menu. You can choose to replace all
existing historical quotes by checking the “Replace existing quotes” check box. Other-
wise, only new quotes will be added.



CHAPTER 5
Working with Portfolios

A portfolio is a collection of investments. Portfolios are used to track the current value,
your capital gains and losses and the historical performance of your investments. In-
vestoscope lets you track any number of portfolios.

Portfolios may be organized in portfolio folders. Portfolio folders provide a consoli-
dated view of multiple subportfolios. All subportfolios of a portfolio folder must have
the same base currency.

5.1 Creating a Portfolio

To create a new portfolio, choose File > New > Portfolio. . . . This will open the following
sheet:

Next, enter the name and select a base currency for the portfolio. Click OK to create
the portfolio. Your new portfolio will now appear in the portfolios section of the source
list.

5.2 Creating a Portfolio Folder

To create a portfolio folder, choose File > New > Portfolio Folder and enter a name (di-
rectly in the sidebar). To populate the portfolio folder, drag existing portfolios or port-

19
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folio folders from the source list into the newly created portfolio folder.

5.3 Adding and Removing Cash

Portfolios in Investoscope maintain a cash balance. You add cash to a portfolio by
entering a Deposit transaction. To do that, first select the portfolio in the source list and
then choose Transactions > Deposit. . . You will then see the following sheet:

To complete the transaction, enter the amount, date and optionally some notes and click
the OK button.

Similarly, to remove cash from a portfolio, you enter a Withdrawal transaction. To
do that, again select the portfolio and choose Transactions > Withdrawal. . .

5.4 Opening Positions (Adding Investments)

New positions are added using either Buy, Short Sell or Transfer-in transactions. Buy
and Short Sell transactions affect the cash balance of the portfolio. Transfer-in trans-
actions can be used to open both short and long positions without affecting the cash
balance.

To enter a Buy transaction, first select the instrument to buy and then choose Trans-
actions > Buy. . . This will bring up the following sheet:
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Once you have entered the number of shares and a price, Investoscope will automati-
cally fill out the commission for you, based on the settings in the Portfolio pane of the
preferences. Click the OK button to complete the Buy transaction.

Entering Short Sell and Transfer-in transactions is similar except that you choose
Transactions > Short Sell. . . or Transactions > Transfer-in. . . , respectively.

5.5 Reducing Positions (Removing Investments)

Long and short positions are reduced (or closed entirely) by entering Sell and Short
Cover transactions, respectively. The amount is added to the cash balance of the portfo-
lio. Transfer-out transaction can be used to reduce a position without affecting the cash
balance.

To enter a Sell transaction, you first select the position to sell in the Holdings pane
of the portfolio that you want to sell from. Then, choose Transactions > Sell. . . . This will
bring up the following sheet:
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Once you have entered the number of shares and a price, Investoscope will automati-
cally fill out the commission for you, based on the settings in the Portfolio pane of the
preferences.

The accounting method pop up buttons lets you choose exactly how the capital
gain/loss is calculated:

Investoscope supports the following accounting methods:

First In, First Out In this method (also known as FIFO), the shares first bought are the
first to be sold.

Last In, First Out With Last In, First Out (also known as LIFO), the new shares are
chosen first.

Average With this method, the capital gain is calculated using the average cost basis of
all the lots.

Maximize Gain and Minimize Gain With the Maximize Gain method, the lots with
the lowest cost bases are chosen first. With, the Minimize Gain method, on the
other hand, the lots with the highest cost bases are chosen first.
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Specific Lot Identification This method lets you specifiy exactly how many shares of
each lot you are selling.

You can view the available lots by choosing View Lots. . . from the Accounting Method
menu:

To complete the Sell transaction, click the OK button.

Entering Short Cover and Transfer-Out transactions is similar except that you choose
Transactions > Short Cover. . . or Transactions > Transfer-Out. . . , respectively.

5.6 Income Transactions

Dividends, interest and other kinds of income are entered using Income Transactions. For
each income you enter, you specify an income category. The Income report (see Section
5.14) will show the income broken down into the specified income categories. You
can define your own income categories to suit your particular needs. To edit income
categories, choose View > Income Categories. . . .

To enter an income transaction, first select the appropriate instrument and then
choose Transactions > Dividend/Interest. . . . Investoscope will then display the follow-
ing form:
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The form lets you enter an amount for each of your income categories. When you click
the OK button, Investoscope will add an income transaction for each income category
that you have entered non-zero amounts for. If you later need to change the income,
the added income transactions can be edited individually from the Transactions pane.

5.7 Return of Capital

A Return of Capital is a payment that exeeds the growth of the investment. In Investo-
scope, a payment entered using a Return of Capital transaction, is deducted from the
cost basis of the position and the amount is added to the cash balance of the portfolio.
In other words, when entering a Return of Capital, you will see your cost basis lowered
and hence your unrealized gain raised. To enter a Return of Capital transaction, select
the instrument and choose Transactions > Return of Capital. . . This will bring up the
following form:
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To complete the transaction, enter the amount and date and click the OK button.

5.8 Investment Expenses

In Investoscope, Expense transactions are used to record expenses associated with a
particular investment. The recorded expense is added to the cost basis of the postion.
The amount is deducted from the cash balance of the portfolio. Thus, an expense can
be considered the opposite of a return of capital. To enter an Expense transaction, select
the instrument and choose Transactions > Expense. . .

5.9 Cost Basis Adjustment

If, for one reason or another, you need to adjust the cost basis of a position without af-
fecting the cash balance of your portfolio, you can enter a Cost Basis Adjustment transac-
tion. With a Cost Basis Adjustment transaction, the recorded amount is subtracted from
the cost basis, but the cash balance of the portfolio remains unchanged. You can enter
a negative amount to make your cost basis greater. To enter a Cost Basis Adjustment
transaction, select the instrument and choose Transactions > Cost Basis Adjustment. . .

5.10 Stock Splits

A stock split is a corporate action in which a company divides each existing share into
multiple shares. The total value of the shares remain unchanged by a stock split. Sim-
ilarly, a reverse stock split reduces the number outstading shares in a company. We refer
to both stock splits and reverse stock splits as simply stock splits. Stock splits affect the
number of shares you own and the price per share, but your cost basis is unaffected.

When you enter a stock split in Investoscope, it applies globally to all your portfo-
lios. Once you have entered a stock split, stock split transactions will be automatically
added and removed when appropriate to all your portfolios. The original purchase
transactions will not be affected.
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Entering a Stock Split To enter a stock split, select the stock and choose Transactions
> Stock Split. . . . This will display the following dialog:

To complete the stock split, enter the split ratio, the split date and click the OK button.
Once the stock split has been entered, you will see corresponding stock split transac-
tions in all portfolios containing the stock.

Cash in Lieu If you have received cash in lieu for fractional shares, you need to enter
a sell transaction for the fractional shares.

Editing or Deleting a Stock Split To edit a stock split, locate one of the stock split
transactions in the Transactions pane of a portfolio and choose Edit Stock Split. . . from
the context menu. To delete a stock split, choose Delete Stock Split from the context
menu. Deleting or editing a stock split applies globally to all your portfolios.

Stock Splits and Historical Quotes When calculating historical values, Investoscope
assumes that historical quotes are split adjusted. When you enter a stock split, Investo-
scope will automatically split adjust the existing quotes, if they do not already appear
to be so.

5.11 Allocation

The pie chart on the “Summary” pane displays your portfolio’s current allocation. You
can choose to see the allocation into individual instruments, instrument types, asset
classes, sectors, etc.
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In Investoscope, the asset class of an instrument is either stock, bond, cash, or other. Bonds
with the “cash equivalent” option checked are counted as cash (along with the cash
balance of the portfolio):

For mutual funds and ETFs, the allocation into assets classes, sectors and market caps
is specified in the “Assets” pane of the sidebar (see Section 3.9).

5.12 Realized Gains and Losses

The “Realized” pane displays your realized gains and losses. At the bottom of the pane,
you can filter the displayed lots by period and/or instrument. Just as with instrument
lists, the rows in it can be grouped by different attributes. Below the rows are grouped
by “Holding Period”:
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Filtering and grouping can be combined in lots of different ways. You can customize
the exact columns to display using the menu View > Columns or by Control-clicking the
table header.

5.13 Transactions

The “Transactions” pane displays the transactions of the selected portfolio. Again, the
rows can be grouped in different ways. Here, the transactions are grouped by year:
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At the bottom of the pane, you can choose to filter the displayed lots by period and/or
instrument and you can customize the exact columns to display using the menu View
> Columns or by Control-clicking the table header.

5.13.1 Editing or Deleting Transactions

You can edit a transaction either by double-clicking it or by choosing Edit Transaction. . .
from the context menu.

To delete a transaction, select it and then choose Delete Transaction. . . from the context
menu, or alternatively, press the delete key on your keyboard.

5.13.2 Moving Transactions

You can move transactions to any other portfolio with the same base currency. To do
that, select one or more transactions and choose the target portfolio from the Move to
Portfolio submenu of the context menu. Alternatively, you can simply drag the transac-
tion to the target portfolio in the source list.

5.14 Portfolio Reports

The Reports tab of the portfolio view provides a number of useful portfolio reports.
You select the report and the date range at the bottom of the screen:

The following subsections describe the available reports.

5.14.1 Capital Gains and Losses

There are three variants of the capital gains report. The “Capitals Gains – Simple”
report shows the realized capital gains and losses within the selected period.
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The “Capital Gains – Short and Long Term” report shows the short-term and long-
term realized capital gains and losses. The holding period defining short-term vs. long-
term can be specified in the Portfolio pane of the preferences.

Finally, the “Capital Gain – Average” shows exactly one row per sale. This is useful
if you are not interested in the gains and losses of the individual lots.

The following is an example of a “Capitals Gains – Simple” report:

5.14.2 Income

The Income report shows a summary of the recorded dividends and interest:
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Note that this report does not include return-of-capital distributions.

5.14.3 Performance

The performance report provides insight into how well your portfolio has performed
in a given period:
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The first two columns show the initial and end values, respectively, for the period.
The Gain/Loss column shows the combined realized and unrealized gain witin the
selected period. The Distributions column shows the sum of the recorded distributions
in the period. The Total Gain/Loss column shows the sum of the capital gain (both
realized and unrealized) and the recorded distributions. Finally, the right-most column
in the performance report shows the internal rate of return (IRR). For periods longer
than one year, the IRR is annulized. For shorter periods, the IRR is not annualized. See
Section 5.15 for the precise definition of the IRR.

The Initial Value column displays the value of the position at the beginning of the
report period. If the start date lies before the purchase date, the Initial Value is 0 (which
can be a bit confusing at first). If the start date is later than the purchase date, the Initial
Value is the market value at the start date, calculated using the historical closing price
of day before the start date (if available).

The End Value column displays the value of the position at the end of the report pe-
riod. This may be 0, if the entire position has been sold before the end date. Otherwise,
the end value is calculated using the latest available price earlier than the end date.

Please note that to accurately calculate historical values of the portfolio, Investo-
scope relies on historical quote prices. If historical quote prices are not available, or if
they are not accurate, the calculated historical position value will not be correct.

5.14.4 Trades

The Trades report shows all the trade transactions recorded within the selected period.
Trades include buy, sell, short sell, short cover, transfer-in and transfer-out transactions.
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5.15 Internal Rate of Return

The Internal rate of return (IRR) is a measure commonly used to compare the profitabil-
ity of investments. IRR is sometimes refered to as the discounted cash flow rate of return
(DCFROR) or simply the rate of return (ROR).

Definition Given a sequence of cash flows C0, . . . , Cn for periods at regular intervals,
the internal rate of return r is given by:

n∑
i=0

Ci

(1 + r)i
= 0

The periods are often given in years, but may also be given in months, weeks or even
days. In fact, Investoscope internally calculates the IRR using days and then converts
the result to a longer period (e.g. years) afterwards. The following items are counted as
cash flow:

• The value at the beginning of the period is a negative cash flow.

• The cost basis for any purchases made in the period are counted as negative cash
flows.

• Distributions, i.e., dividends, interest, capital gain distributions, return of capital,
etc. count as positive cash flows.

• Proceeds from sales in the period are counted as positive cash flows.



5.16. Portfolio Charts 34

• The value at the end of the period is credited as a positive cash flow.

Reinvested dividends are not counted as cash flow, since from a cash flow point of view
such transactions are zero-sum. In stead, they affect the performance later either from
sales or from the value at the end of the period.

Investoscope calculates the IRR using an iterative method starting with a guess. The
iteration continues until a sufficiently accurate result is reached. If a result cannot be
found within 100 iterations, Investoscope will give up.

5.16 Portfolio Charts

The “Charts” pane displays your portfolio value over time:

You can choose between two chart types:

Portfolio Value This chart plots the total value of the portfolio including the cash bal-
ance along with the deposited cash.

Equity Value This chart plots the value of your open positions along with the cost
basis. The cash balance is not included.

You can set the data range to be plotted with the “Period” pop up button.

Note In order for the portfolio charts to be accurate, historical end-of-day quotes must
be available for all instruments in your portfolio.



CHAPTER 6
Importing Transactions

Rather than entering your transactions manually, you can choose to import them from
a file. Investoscope supports import from either CSV or OFX files. Most financial insti-
tutions let you download your transactions in one of these formats.

6.1 Importing Transactions from OFX

Open Financial Exchange (OFX) is a stardard for exchanging financial information. In-
vestoscope supports import from OFX version 2 files. To import an OFX file, choose
File > Import > Transactions from OFX File. . . . Then, select the OFX file to import and
click the Open button. You should then see a window like the following:

The checkboxes let you exclude individual transactions from the import. By default,
Investoscope will exclude any transactions that it detects have already been imported
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to the selected portfolio. To complete the import, choose a portfolio to import to and
click the Import button.

6.2 Importing Transactions from CSV

Comma Separated Values (CSV) is a very generic tabular data format. This makes import-
ing from CSV slightly more complicated than importing OFX (which was specifially
designed for the kind of data that applications like Investoscope work with).

Note that Investoscope imports transactions, so please make sure that your CSV file
actually contains your transactions and not just your current holdings. We will explain
the process of importing a CSV file using an example:

Example Say, we want to import a CSV file with the following content:

"2008-02-27","Purchase","EBS ",800,7.02,1.0000,22.00,-5638.00
"2010-05-03","Sell","DELL ",-500,16.46,1.0000,12.00,8218.00
"2007-11-02","Short Sell","MSFT ",-400,37.06,1.0000,40.00,14784.00
"2008-11-19","Sell","EBS ",-1200,20.15,1.0000,5.00,24175.00
"2010-07-14","Sell","VWS.CO",-100,267.00,0.1759,0.00,4696.53
"2007-10-04","Purchase","GOOG ",25,585.09,1.0000,40.00,-14667.25
"2007-12-08","Purchase","AAPL ",100,166.73,1.0000,40.00,-16713.00
"2007-12-01","Deposit",,,,,,50000.00

To begin the import, choose File > Import > Transactions from CSV File. . . , select the
CSV and click the Open button.

The Import Window You should now see the import window. The import window
consists of two parts. The first part is the actual content of the CSV file, presented in
a table. The second part is a preview of what transactions will be imported using the
selected settings:
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Above, you will notice that the preview area is empty. Also, note the warning triangle
in each line. The warning triangle is displayed for each line that Investoscope is unable
to import with the current settings. If you hover the mouse over the warning triangle,
you should see a message indicating why the given line could not be imported. In our
case, it says “No instrument column assigned”. That is because we haven’t yet told
Investoscope what each column in the file means.

Assigning Meaning to Columns Investoscope has already guessed that the first col-
umn is a date column and the second one specifies the transaction type. We need to tell
Investoscope in which columns to find the instrument, the number of shares, the price,
etc. To do that, click the on the column header and choose the appropriate field. After
doing that, you should see the following:



6.2. Importing Transactions from CSV 38

Investoscope will remember the chosen settings, so the next time you import a CSV file
with a similar format, Investoscope will automatically associate the appropriate type to
each column.

Interpreting Transaction Types There are still three remaining warning triangles. Hov-
ering the mouse over the first one, reveals the following message: “Transaction type
’PURCHASE’ not recognized.” This means Investoscope doesn’t know how to inter-
pret ‘PURCHASE’ as a transaction type. It should, of course, be interpreted as a Buy
transaction. To instruct Investoscope to do this, click the Transaction Tyoes. . . button.
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Here you can map the contents of transaction type column to Investoscope’s trans-
action types. To proceed, click the + button and type “PURCHASE” (casing doesn’t
really matter here) in the value field and select “Buy” in the Transaction Type column
as shown above.

Dividends and interest are recorded using Income transactions. When importing
from CSV, the income category is determined is one of two ways:

1. An ‘Income Category’ column is assigned.

2. If no ‘Income Category’ column is assigned, the category is taken to be the con-
tents of the transaction type column.

Mapping to Instruments in Your Library The instruments referenced by the CSV file,
must be in your library. If an instrument is not already in your library, you can switch
to the main window and add without closing the import panel. If the instrument is in
the library, Investoscope will often be able to determine the mapping from contents of
the assigned instrument column to instruments in the library. Sometimes, though, you
may need to help it along. You do that by clicking the Instrument. . . button.



CHAPTER 7
Watchlists

7.1 Monitoring the Markets

A watchlist is a custom collection of instruments. Watchlists allow you to organize and
monitor instruments that you don’t necessarilly own. There are two different kinds of
watchlists in Investoscope: Smart watchlists and regular watchlists. Additionally, watch
lists can be organized in watchlist folders.

Smart watchlists contain all instruments that match the criteria you specify. Watchlist
folders allow you to organize your watchlists in hierarchies. The contents of a watchlist
folder is the union of the contained sub-watchlists. Regular watchlists, on the other
hand, are managed directly, that is, you can drag instruments to them and delete in-
struments from them.

7.2 Creating a (Regular) Watchlist

To create a new watchlist, choose File > New > Watchlist from the main menu. A newly
created watchlist will then appear in the source list and you can give it the name you
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want:

7.2.1 Adding Instruments to Watchlists

You can add instruments to a watchlist by dragging them from anywhere else in In-
vestoscope into the watchlist in the source list.

Alternatively, you can add instruments to a watchlist through the context menu. To
do that, hold the Control key on your keyboard and click the instrument to open the
context menu. Then, select the watchlist from the Add to menu:

7.2.2 Removing Instruments from Wathclists

You can remove an instrument from a watchlist simply by selecting it and hitting the
delete key on your keyboard. Alternatively, you can remove an instrument from a
watchlist through the context menu. To do that, hold the Control key on your keyboard
and click the instrument to open the context menu. Then, if the instrument is a member
of any watchlist, you will find the submenu Remove from from which you can choose a
watchlist to remove the instrument from:
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Removing an instrument from a watchlist will not delete it from the library.

7.3 Smart Watchlists

Smart watchlists are populated automatically based on some rules that you specify. You
can create watchlists of certain types of instruments with certain labels or currencies, or
instruments that match other rules you specify. Investoscope will update these smart
watchlists automatically.

For example, you could create a Smart Watchlist with the 10 stocks with the highest
change in percent today. Or you could create a Smart Watchlist with all stocks traded
in a given currency. The possibilities are virtually endless.

7.3.1 Creating a Smart Watchlist

To create a smart watchlist, choose File > New > Smart Watchlist. . . This will bring up
the following sheet:
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Select to specify rules. You can deselect this
to match all instruments in your library.

Click to add another rule.

Hold the Option key to add 
another compound rule

Limit the size of the watchlist.

Above, we have chosen rules to include all US stocks. When you are done editing
the filtering rules, click the OK button to create the watchlist. A newly created smart
watchlist will then appear in the source and you can give it the name you want.



CHAPTER 8
Technical Charts

This chapter presents the technical charting capabilities of Investoscope. The reader is
assumed to be familar with technical charting analysis.

Pressing enter on your keyboard with an instrument selected or double-clicking an
instrument takes you to the technical chart view:
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Above, you see an example of a technical chart for Amazon.com Inc. displaying the
Bollinger Bands as overlay to the candlestick chart and below it, the MACD indicator.

At the bottom you find the history map which displays the entire available history of
end-of-day prices and lets you select the date range to display.

The top-most chart contain the price data with or without overlays. You can con-
figure the type of the price data chart (line, candlestick, etc.) by clicking the Settings
button:



8.1. Technical Indicators 46

Here you can also switch between linear and logarithmic scaling of the y-axis, and
choose whether or not to display volume bars, grid lines, history map and more.

8.1 Technical Indicators

Investoscope lets you display a large number of different overlays and oscillators with a
large number of options for customizations.

To add a new indicator to the chart, first click the “Indicators” menu button to bring
forth the indicators menu:

If you, for example, choose “Bollinger Bands” from the menu, that indicator will be
added to the chart, and you can edit the parameters to your liking:
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For help on the indicator, click the ? button. To delete the indicator, click the Delete
button. To hide the indicator pop over, you can either click the Done button or just
anywhere outside the pop over. You can always bring up the indicator parameters
again simply by clicking the indicator chart.

8.2 Working with Chart Templates

The configuration of a chart, i.e., the displayed indicators, scale and other settings can
be saved in a chart template. A template includes all attributes of a chart except the
instrument being displayed.

8.2.1 Saving a Template

Once you have set up your chart, you can save the configuration in a template. To save
a template, click the Template menu button and choose Save Current View as Template. . . :

Then, type in the desired name of the template and click the OK button:
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8.2.2 Applying a Template

When you apply a template the current view is replaced with the configuration saved
in the template. To apply a template, click the Template menu button and choose the
template from the menu:

Notice the keyboard shortcuts for the templates. The first 9 templates can be quickly
applied from the keyboard with the keys “1” through “9”.

8.2.3 Managing Your Templates

You can manage your existing templates by choosing Manage Saved Templates. . . from
the template menu. This will bring up the following panel:

Here you can delete, rename and/or reorder your templates.

8.3 Lines and Text Annotations

From the Draw menu, you can add lines to the main chart to visually indicate trends
and use text annotations to mark interesting points:
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You can select the default color used to draw annotation with the color menu:

8.3.1 Drawing Lines

Investoscope allows you to draw three types of lines: horizontal lines, vertical lines and
trend lines. You can change the default line style from the Line Style menu:

Horizontal Lines Horizontal lines extend indefinitely backward and forward in time
on a fixed price level. To draw a horizontal line, choose Horizontal Line from the Draw
menu and click the mouse button on the main chart to set the price level. With the
mouse held, you can move the price level up and down.
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Vertical Lines Vertical lines extend indefinitely up and down on the price axis at a
fixed time. To draw a vertical line, choose Vertical Line from the Draw menu and click
the mouse button on the main chart to set the time. With the mouse held, you can move
the line back and forth.

Trend Lines A trend line is defined by two anchor points. Trend lines come in two
variations: extending and non-extending. Extending trend lines are extended indefi-
nitely in both directions. Non-extending trend lines are only drawn between the anchor
points. To draw a trend line, select either Trend Line or Trend Line (extending) from the
Draw menu. Then click the mouse on the main chart to set the first anchor point and
with the mouse button held down move it to the position of the last anchor point and
release the mouse. You can move the anchor points, simply by clicking and dragging
them.

8.3.2 Text Annotations

Text annotations can be used to mark points of interest on the chart. To add a text
annotation, choose Text from the Draw menu and click the mouse button at the desired
position of the main chart. To set a fixed maximum width of the text, drag the mouse,
otherwise just release the mouse immediately. You can now enter the text you want:

To finish editing, just click somewhere else on the chart. You can later edit the text
annotation by double-clicking it and move it around by clicking and dragging it with
your mouse. You can change the color, alignment and font of a text annotation through
the Format menu.

8.4 Printing Technical Charts

As with most screens in Investoscope, you can print the current chart, by choosing File
> Print. . .
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You can change the page layout by choosing Page Setup. . .



CHAPTER 9
Maintenance and Administration

9.1 Preferences

Investoscope’s preferences are accessed by choosing Investoscope > Preferences. . . from
the menu. The preference window consists of the panes:

• General

• Labels

• Portfolio

• Security

• Advanced

9.2 Customizing the Location of Investscope’s Data

By default Investoscope keeps its data inside its application container. However, you
can customize the location of Investoscope’s data. This is done in the “Advanced” pane
of the preferences:
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To change the data location, click on the Change. . . button and choose a folder. The
chosen folder must either be empty or contain an Investoscope database. If you choose
an empty folder, your data from the default location will be moved to the new location.
If you, on the other hand, choose a folder that already contains a database, Investoscope
will just switch to using the database at the new location and leave the data at the old
location where it is.

To change the data location back to the default location inside the application con-
tainer, click the Reset button.

9.3 Automatic Backups

As a user you typically invest a significant amount of time maintaining your data in
Investoscope. To help you avoid losing your data, Investoscope automatically creates
a backup of your database whenever you make any changes. Investoscope keeps back-
ups from the last 30 days. You can open the automatic backup folder in the Finder by
choosing File > Open Automatic Backups Folder from the menu.

9.4 Manually Backing Up and Restoring the Database

You can create a backup manually by choosing File > Back Up Database. . . from the
menu and choose a location. To restore a backup, choose File > Revert to Database
Backup. . . from the menu.

9.5 Transfering Your Database to Another Mac

You can use the backup/restore feature to transfer your database from one Mac to an-
other with the following steps:
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1. On the first Mac, create a backup of the database by choosing File > Back Up
Database. . .

2. Transfer the backup to the second Mac, e.g., using an USB stick or over your local
network.

3. On the second Mac, load the backup by choosing File > Revert to Backup. . .

9.6 Exporting Data

Most data in Investoscope can be exported to CSV (Comma Separated Values) files. The
export options are available from the File > Export menu:

All table views, that is, all instrument lists, including watchlists and portfolio hold-
ings, displayed in List View, as well as the Transactions and Realized panes of a port-
folio can be exported to CSV. To do that, choose File > Export > Current View to CSV. . . .
This will export currently the displayed rows and columns to a CSV file.

To export all transactions of a portfolio, first select the portfolio in the source list
and then choose File > Export > All Transactions to CSV. . .

Finally, the historical quotes of an instrument can be exported to CSV. To do that,
first select the instrument and then choose File > Export > Historical Quotes to CSV. . . .
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